Joomla, "403 Forbidden"

Discussion in 'Web Design' started by LouTheDesigner, Jan 22, 2009.

to remove all ads.
  1. LouTheDesigner

    LouTheDesigner New Member

    Messages:
    506
    Okay, so this is my first time installing Joomla, and I'm pretty sure I've left out some minor step.

    When I try to access the folder on my site into which I have installed Joomla, I get a "403 Forbidden" message. All of the files have been uploaded successfully. Is this because I have installed it into a subfolder? (www.ficodesigns.com/joomla). The /joomla is the name of the folder into which I installed the joomla files.

    Thanks in advance.
     
  2. Matthew

    Matthew New Member

    Messages:
    57
    I think that you need to chmod some files, so changing the permissions. Go back over the installation manual, until you find something about changing permissions of certain files.

    There could be something else that is wrong, but I am pretty sure it is because you have not set appropriate permissions.
     
  3. horrorshow75

    horrorshow75 New Member

    Messages:
    160
    Depending on which ftp software you use you can do it through that. Just right click the folder on the server and choose chmod or permissions, sometime it's under properties it really all depends on the ftp client. You'll probably want to 775 the joomla folder.

    This equates to something like
    Owner - Read, Write, and Execute
    System - Read, Write, and Execute
    Public - Read
     
  4. LouTheDesigner

    LouTheDesigner New Member

    Messages:
    506
    thanks guys,

    I've been using CyberDuck lately for ftp(which I love), but I think I'll have to switch to CuteFTP to change the permission.
     
  5. Matthew

    Matthew New Member

    Messages:
    57
    I don't think you would want to do the whole folder. It should actually just be a file named something like config.php.
     
  6. LouTheDesigner

    LouTheDesigner New Member

    Messages:
    506
    Okay, So I gave 775 permission to the joomla folder, and now I'm getting a "500 Internal Server Error."
     
  7. Matthew

    Matthew New Member

    Messages:
    57
    Told ya you should not have done it ;) Though I am lost what you should do know, hopefully horrorshow75 can fix the issue.

    edit: posted a second after lol
     
  8. Matthew

    Matthew New Member

    Messages:
    57
    You did go through the installation file didn't you?
     
  9. horrorshow75

    horrorshow75 New Member

    Messages:
    160
    This is what I see...

    worst case scenario...chmod back to what it was and we'll go from there. But I can say that it doesn't appear to be a permissions issue anymore.
     
    Last edited: Jan 22, 2009
  10. horrorshow75

    horrorshow75 New Member

    Messages:
    160
    Are you manually installing this or using something like fantastico?
     
  11. Matthew

    Matthew New Member

    Messages:
    57
    Fantastico would chmod the files for you, I think.
     
  12. horrorshow75

    horrorshow75 New Member

    Messages:
    160
    I'm not sure. It may for joomla but I know I have installed other apps in the past to play around with and recall having to chmod some files. So I think it depends on how the installer is setup and I don't know if that is setup by the host or if fantastico is an off the shelf same for every host kind of thing.
     
  13. LouTheDesigner

    LouTheDesigner New Member

    Messages:
    506
    I'm not exactly sure. What I have done is this. I set up a new database on my web server. Then I downloaded the latest version of Joomla. Then I uploaded all of the joomla files to my web server. What do I do from there? How do I get to the installation file?
     
  14. horrorshow75

    horrorshow75 New Member

    Messages:
    160
  15. LouTheDesigner

    LouTheDesigner New Member

    Messages:
    506
    It turns out that I just didn't have cgi enabled. But hey, it's working!. Time to embark on a CMS adventure while watching Burn Notice. Thanks for the replies everyone!
     
  16. Matthew

    Matthew New Member

    Messages:
    57
    Have Fun with it!
     
  17. ngchongyang

    ngchongyang New Member

    Messages:
    4

Share This Page