contact form action php

Discussion in 'Web Design' started by Manganix, May 15, 2015.

to remove all ads.
Thread Status:
Not open for further replies.
  1. Manganix

    Manganix Member

    Messages:
    112
    Hi,


    could you please check what is going wrong?

    When I click on the send button in the contact section, it jumps to the php page instead of sending the mail and echoing the success message:


    Thanks for your help.

    http://gamanga.com/
     
  2. chrishirst

    chrishirst Well-Known Member Staff Member

    Messages:
    2,662
    Because you use one of these crappy, annoying "one page AJAX 'ever scroll' " things, with a form that has NO action defined in it so does NOT intrinsically 'know' what to do when it becomes 'self referencing' (submitting to the URL it is served by).
     
  3. ronaldroe

    ronaldroe Super Moderator Staff Member

    Messages:
    1,223
    You've added your action URL to the name attribute. Change name to action and see if that doesn't fix it.
     
  4. Manganix

    Manganix Member

    Messages:
    112
    hey ronaldroe,


    thanks for the suggestion.
    I actually started with "action", but when that didn't work, I tried it with "name". No game so far...

    When pushed "send" button, the index page jumps to the .php file, where I need to refill the captcha ... after this it works great and the "thank you" message appears.
     
  5. Manganix

    Manganix Member

    Messages:
    112

    thanks for your reply, but I can't make anything out of this. I can read it (for starters ;-) ) but can't take it / link it to the problem and its solution... Must be my very limited coding 'knowledge'.
     
  6. chrishirst

    chrishirst Well-Known Member Staff Member

    Messages:
    2,662
  7. Manganix

    Manganix Member

    Messages:
    112
    the contact form should be working now, with captcha and confirmation/validation success.

    Thanks for checking the form and your feedback ;-)

    http://gamanga.com/
     
  8. tk-hassan

    tk-hassan New Member

    Messages:
    10
    just tested your contact form, from Front-End it seems working
     
  9. Manganix

    Manganix Member

    Messages:
    112
    received your testmail, seems OK!

    Thanks for testing and feedback.
     
Thread Status:
Not open for further replies.

Share This Page